Подсчет Повторов в MS EXCEL

Произведем подсчет всех повторов в списках ЧИСЛОвых и ТЕКСТовых значений.

Если исходный список содержит: {1, 1, 1, 2, 2, 3}. Тогда количество повторов, будет равно 3, т.к. числа 1, 1 и 2 являются повторами.

Решение 1

Если исходный список значений находится в диапазоне А6:А15, то число повторов можно вычислить с помощью формулы (см. файл примера):
=СУММПРОИЗВ(--(ПОИСКПОЗ(A6:A15;A6:A15;0)<>СТРОКА(A1:A10)))

или

=СУММПРОИЗВ(--(ПОИСКПОЗ(A6:A15;A6:A15;0)<>СТРОКА(ДВССЫЛ("A1:A"&СЧЁТЗ(A6:A15)))))

Диапазон не должен содержать пустые ячейки. Формула подсчитывает числовые и текстовые значения.

Решение 2

Другой вариант - формула массива:

=ABS(СУММ(ЕСЛИ(СЧЁТЕСЛИ(A6:A15;A6:A15)>1;(1/СЧЁТЕСЛИ(A6:A15;A6:A15))-1;0)))

Пустые ячейки формулой игнорируются. Формула подсчитывает числовые и текстовые значения. После ввода формулы, вместо нажатия ENTER, нажмите CTRL+SHIFT+ENTER.

Решение 3

Решение заключается, чтобы отнять от общего количества значений число уникальных:

=СЧЁТЗ(A6:A15)-СУММПРОИЗВ((A6:A15<>"")/СЧЁТЕСЛИ(A6:A15;A6:A15&""))

Формула только для числовых значений:

=СЧЁТ(A6:A15)-СУММПРОИЗВ(--(ЧАСТОТА(A6:A15;A6:A15)>0))

Примечание. В отличие от статьи Подсчет повторяющихся значений (дубликатов), где подсчитывались все дубликаты, подсчитаем только повторы (повторяющиеся за исключением первого дубликата). Чтобы не запутаться в этом зоопарке терминов, можно обратиться к статье Классификация значений по уникальности.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 4 (2 оценок)
Яндекс.Метрика