Подсчет количества выходных дней в диапазоне дат MS EXCEL

Подсчитаем количество выходных дней, содержащихся в диапазоне дат. Даты введены в ячейки листа. Выходными днями считаются суббота и воскресенье (праздники не учитываются).

Пусть дан перечень дат (не обязательно идут подряд).

Формула =СУММПРОИЗВ(--(ДЕНЬНЕД(A6:A15;2)>5)) подсчитает количество выходных в диапазоне A6:A15 (см. файл примера).

Если необходимо подсчитать количество выходных для подрят идущих дат, начиная с определенной даты, то используйте формулу 

=СУММПРОИЗВ(--(ДЕНЬНЕД(A22+СТРОКА(ДВССЫЛ("A1:A"&B22))-1;2)>5))

Предполагается, что в А22 введена начальная дата, а в В22 - количество значений. Выражение СТРОКА(ДВССЫЛ("A1:A"&B22)) задает массив последовательных чисел, начиная с 1. Далее к начальной дате последовательно прибавляется 1, 2 и т.д., т.е. формируется диапазон подряд идущих дат.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 3.7 (3 оценок)

Комментарии

MCH

По приложенному примеру. Количество выходных для подряд идущих дней можно вычислить по формуле:
=B22-ЧИСТРАБДНИ(A22;A22+B22-1)