Подсчет ЧИСЕЛ попадающих в интервал в MS EXCEL

Подсчет чисел, попадающих в интервал – стандартная задача: используйте функцию СЧЕТЕСЛИМН(). Усложним задачу, сделаем интервал легко настраиваемым.

В качестве примера подсчета чисел возьмем список с числовыми значениями от 4 до 30 (См. файл примера).

Будем подсчитывать значения, попадающие в интервал, например, (4;15]. Причем, границы интервала «включает [ ]» и «не включает ( )» будем выбирать из Выпадающего (раскрывающегося) списка.

Примечание: решение без выбора интервалов =СЧЁТЕСЛИМН(A2:A12;">"&D2;A2:A12;"<="&F2) Предполагается, что границы интервала введены в ячейки D2 и F2. Эти ячейки не должны быть пустыми, даже если одна из границ =0. Если в диапазоне A2:A12 содержатся числовые значения в текстовом формате, то они будут проигнорированы.

Для настройки границ интервала используем Проверку данных с типом данных Список. В качестве источника укажем для левой границы >;>= и для правой <;<=. Границы интервала будем вводить в диапазон H2:I3.

Подсчет можно реализовать множеством формул, приведем несколько:

  • =СЧЁТЕСЛИМН(A2:A12;C2&D2;A2:A12;E2&F2)
  • =СЧЁТЕСЛИ($A$2:$A$12;C2&D2)-(СЧЁТЗ($A$2:$A$12)-СЧЁТЕСЛИ($A$2:$A$12;E2&F2))
  • Формула =БСЧЁТ(A1:A12;A1;H2:I3) требует предварительного создания таблицы с условиями. Заголовки этой таблицы должны в точности совпадать с заголовками исходной таблицы.

СОВЕТ:
Более сложные условия подсчета рассмотрены в статье Подсчет значений с множественными критериями (Часть 1. Условие И).

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 4.4 (7 оценок)