Отображение в MS EXCEL ЧИСЕЛ в формате миллионов и тысяч

Если ячейка содержит значение больше 1000, то часто не требуется указывать точное значение, а достаточно указать число тысяч или миллионов, один-два знака после запятой и соответственно сокращение: тыс. или млн.

Если необходимо, чтобы вводимые числовые значения отображались в формате миллионов и тысяч с нотацией соответственно млн. или тыс. (например, 551 200 отобразить в виде 551,2 тыс., а 5 567 634 в виде 5,6 млн.), то для реализации этого существует 2 принципиально разных подхода.

Использование формулы

Очевидным подходом для получения желаемого результата является использование простой формулы и, соответственно, дополнительной ячейки, куда эта формула вводится (см. файл примера):
=ЕСЛИ(A1<1000;
A1;
ЕСЛИ(A1<1000000;ОКРУГЛ(A1/1000;1)& " тыс.";ОКРУГЛ(A1/1000000;1)& " млн."))

Результат формулы – текстовое значение. Надо также иметь ввиду, что из-за округления число 999 990,00, например, будет отражено в виде 1000,0 тыс.

В файле примера также создана формула на отрицательных значений.

Пользовательский формат

Если нет желания использовать дополнительную ячейку, то с помощью пользовательского формата можно изменить, лишь отображение значения в ячейке, а не само значение.

Пользовательский формат вводим через диалоговое окно Формат ячеек.

  • для вызова окна нажмите CTRL+1;
  • выберите (все форматы),
  • удалите все из поля Тип;
  • в поле Тип введите [>1000000]#,0  " млн";[>1000]#,0 " тыс.";# ##0,00

Очень важно ввести правильно все пробелы, т.к. пробелы разделяют числовые разряды. Для корректного отображения ниже приведена формула с явным указанием местонахождения пробела (пробел заменен словом Space).
[>1000000]#,0SpaceSpace" млн";[>1000]#,0Space" тыс.";# ##0,00

При применении такого пользовательского формата будет произведено округление, т.е. число 1 290 000 будет отображено как 1,3 млн., а 1 240 000 как 1,2 млн.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 4.3 (6 оценок)

Комментарии

Иван (не проверено)

Такой запрос то это понятно, а вот как провернуть эту же фишку со сводными таблицами

Creator

@#1 Иван, к ячейкам Сводной таблицы, содержащим числовые значения, нужно применить пользовательский формат, указанный в статье. Не понятно о каком "запросе" идет речь.

 

Мадияр (не проверено)

спасибо!!!