Отбор уникальных значений с вычислением среднего из соседнего столбца в MS EXCEL

Имеется таблица, состоящая их двух столбцов: из столбца с повторяющимися текстовыми значениями и столбца с числами. Создадим таблицу состоящую только из строк с уникальными текстовыми значениями. По числовому столбцу произведем вычисление среднего.

Разовьем идеи, изложенные в статье Отбор уникальных значений (убираем повторы).

Пусть исходная таблица содержит 2 столбца: текстовый – Список регионов и числовой - Объем продаж. Столбец Список регионов содержит повторяющиеся значения (см. файл примера). Уникальные значения выделены цветом с помощью Условного форматирования.

Задача

Создадим на основе исходной, таблицу, в которой в столбце с перечнем регионов будут содержаться только уникальные названия регионов (т.е. без повторов), а в соседнем столбце будут вычислены средние продажи для каждого региона.

Решение

Создадим Динамические диапазоны: Регионы (названия регионов из столбца А) и Продажи (объемы продаж из столбца B).

Если в исходный список будет добавлено новое значение, то оно будет автоматически включено в Динамический диапазон и нижеследующие формулы не придется модифицировать.

Для создания списка уникальных значений введем в ячейку D2 формулу массива:
=ЕСЛИОШИБКА(ИНДЕКС(Регионы; ПОИСКПОЗ(0;СЧЁТЕСЛИ($D$1:D1;Регионы);0));"")

Для подсчета средних продаж в столбце E запишем формулу:
=ЕСЛИОШИБКА(СУММЕСЛИ(Регионы;D2;Продажи)/ СЧЁТЕСЛИ(Регионы;D2);"")

Отображение нулей в строках, в которых нет регионов, уберем пользовательским форматом # ##0;-# ##0; (см. статью Скрытие значений равных 0).

Тестируем

1. Введите в ячейку А11 новый регион - Китай
2. Введите объем продаж - 100
3. Введите в А12 - Китай
4. Введите объем продаж - 500
5. В соседней таблице справа в ячейке D7 будет выведено название региона Китай со средним объемом продаж 300

 

СОВЕТ:
Другим подходом к решению этой задачи является использование Сводных таблиц.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (1 оценка)

Комментарии

Сергей (не проверено)

Спасибо за прекрасную статью. Она мне, ох как, сохранила нервных клеток и часов работы :)

viktorlom

Уже 5 часов не могу правильно все составить даже на вашем примере!!! Не могли бы вы применительно к вашему примеру, без всяких ссылок на другие статьи, объяснить как создать динамический диапазон, что куда в какую ячейку вставить???!!!

viktorlom

Позарез нужна эта формула! Вы можете пошагово объяснить что, где в какой ячейке написать. Повторы успешно убрал. С остальным ничего не получается! Ничего в этой статье нет где и как создать динамические диапазоны продажи и регионы и как куда вносить формулы. Поясните пожалуйста!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Яндекс.Метрика