Отбор неповторяющихся значений в MS EXCEL

Имея список с повторяющимися значениями, создадим список, состоящий только из значений, которые не повторяются.

Пусть в столбце А имеется список с повторяющимися значениями, например список с названиями компаний.

Задача

В некоторых ячейках исходного списка имеются повторы, а новый список неповторяющихся значений не должен содержать значений, которые повторяются (неповторяющиеся значения в исходном списке выделены с помощью Условного форматирования).

Решение

Список неповторяющихся значений создадим в столбце B с помощью формулы массива (см. файл примера).

Введем в ячейку B5 формулу массива:
=ЕСЛИОШИБКА(ИНДЕКС($A$5:$A$19;
ПОИСКПОЗ(0;СЧЁТЕСЛИ(B4:$B$4;$A$5:$A$19)+(СЧЁТЕСЛИ($A$5:$A$19;$A$5:$A$19)<>1);0)
);"")

Для ввода формулы массива вместо ENTER нужно нажать CTRL + SHIFT + ENTER.

Скопируйте формулу вниз с помощью Маркера заполнения (размерность списка неповторяющихся значений должна совпадать с размерностью исходного списка).

Создание списка с неповторяющимися значениями не стоит путать с созданием списка уникальных значений (см. статью Отбор уникальных значений (убираем повторы)). В файле примера в столбце С для сравнения приведен список уникальных значений.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (1 оценка)