Отбор неповторяющихся значений со значениями из соседнего столбца в MS EXCEL

Имея список с повторяющимися текстовыми значениями, создадим список, состоящий только из неповторяющихся значений. А из столбца соседнего с исходным, выведем соответствующие им числовые значения.

Пусть исходная таблица содержит 2 столбца: текстовый – Список регионов и числовой - Объем продаж. Столбец Список регионов содержит повторяющиеся значения (см. файл примера).

Названия регионов в исходной таблице, которые не имеют повторов и соответственно должны быть выведены, выделены цветом с помощью Условного форматирования.

Задача

Создадим таблицу, в которой в столбце с перечнем регионов будут содержаться только те значения из исходной таблицы, которые не имеют повторов (т.е. те, которые выделены Условным форматированием), а рядом выведем соответствующие объемы продаж.

Решение

Для создания списка неповторяющихся значений введем в ячейку D2 формулу массива:
=ЕСЛИОШИБКА(ИНДЕКС(Регионы;НАИМЕНЬШИЙ(
ЕСЛИ(СЧЁТЕСЛИ(Регионы;Регионы)=1;СТРОКА(Регионы)-СТРОКА($A$1));
СТРОКА(A1)));"")

Динамический диапазон Регионы представляет собой исходный столбец с названиями регионов, причем его границы изменяются в зависимости от количества числа введенных значений в столбец А (пропуски не допускаются). Аналогичный диапазон Продажи создан для столбца Объем продаж. Теперь при вводе новых (неповторяющихся) значений в столбцы А и В, таблица с неповторяющимися значениями будет обновляться автоматически.

Соответствующие неповторяющимся значениям из столбца Объемы продаж выведены в столбце E с помощью формулы:
=ЕСЛИОШИБКА(ВПР(D2;$A$2:$B$15;2;ЛОЖЬ);"")

Тестируем

1. Введите в ячейку А11 новый регион - Вьетнам
2. Введите объем продаж - 100
3. В соседней таблице справа в ячейке D7 будет автоматически выведено название региона Вьетнам с соответствующим объемом продаж.

СОВЕТ:
Другим подходом к решению этой задачи является использование Сводных таблиц.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (1 оценка)