Объединение 2-х списков в MS EXCEL

Иногда для удобства требуется объединить два списка значений в один.

Пусть имеется 2 списка: первый список находится в столбце А, второй в столбце В.

Задача

Объединим 2 списка, содержащие, текстовые значения.

Решение

Эта задача решается простой для понимания формулой (см. Файл примера):
=ЕСЛИ(
СТРОКА()-СТРОКА($C$4)>СЧЁТЗ(Список1);
ИНДЕКС(Список2;СТРОКА(C5)-СЧЁТЗ(Список1)-СТРОКА($B$4));
A5)

Т.е. если мы исчерпали значения из первого списка, начинается выборка из второго. Списки не должны содержать пропусков (пустых ячеек). Для удаления пропусков в списках используйте идеи из одноименной статьи Удаляем пропуски в списке.

Имена Список1 и Список2 представляют собой 2 динамических диапазона.

Наличие динамических диапазонов позволяет добавлять новые значения в исходные списки. При этом, новые значения автоматически попадут в Объединенный список.

СОВЕТ:
Если списков больше, то потребуется подход, приведенный в статье Объединение 3-х и более списков.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (1 оценка)
Яндекс.Метрика