Классификация значений по повторяемости в MS EXCEL

Для устранения двусмысленности толкования терминов: уникальное значение, неповторяющееся значение, дубликат, повтор и пр., в этой статье приведена соответствующая классификация.

При работе со списками повторяющихся значений используются различные термины: уникальные значения, дубликаты, неповторяющиеся и неповторяющиеся значения (см. Пункты в меню Уникальные и Повторы). Чтобы не запутаться, приведем терминологию и классифицируем значения по повторяемости.

  • Неповторяющиеся значения: значения, которые не повторяются, т.е. встречаются в исходном списке один раз;
  • Уникальные значения: все значения, за исключением их повторов (определение повтора см. ниже);
  • Повторяющиеся значения (=дубликаты): значения, которые повторяются, т.е. встречаются в исходном списке более одного раза;
  • Первый дубликат: повторяющееся значение, которое встретилось первым (если двигаться сверху списка). Совокупность всех первых дубликатов и неповторяющихся значений совпадает по определению с совокупностью уникальных значений;
  • Повтор: повторяющееся значение, которое встретилось вторым, третьим и т.д. (если двигаться сверху списка).

В файле примера приведены формулы для подсчета и определения этих значений. Подробности расчетов приведены в соответствующих статьях раздела.

В EXCEL понятия неповторяющихся и уникальных значений трактуются по-разному в зависимости от применяемого инструмента или формулы. Приведем пример из справки EXCEL, статья Подсчет уникальных значений среди повторяющихся значений.

В справке приведена следующая таблица:

Согласно справки, формула подсчета числа уникальных текстовых и числовых значений в ячейках B2:B10 возвратит результат 7. В тоже время, применив к указанному диапазону правило Условного форматирования, получим, что будет выделено только 5 значений.

Таким образом, согласно предложенной в начале статьи терминологии, формула
=СУММ(ЕСЛИ(ЧАСТОТА(ПОИСКПОЗ(B2:B10;B2:B10;0);ПОИСКПОЗ(B2:B10;B2:B10;0))>0;1))

действительно подсчитала уникальные значения (Батурин; 563; 789; 235; Тихонов; 143; 237), а вот Условное форматирование на самом деле выделило неповторяющиеся значения (Батурин; 563; Тихонов; 143; 237).

Для того, чтобы не запутаться, во всех материалах сайта excel2.ru используется терминология, предложенная в начале статьи.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (1 оценка)
Яндекс.Метрика