Какие элементы у 2-х списков в MS EXCEL общие?

Пусть дано 2 списка значений. Определим, какие элементы первого списка содержатся во втором.

Пусть Список1 находится в диапазоне A2:A17, Список2 - в диапазоне B2:B9.

Определим какие элементы из первого списка присутствуют во втором (см. Файл примера).

Решение основано на формуле =СУММПРОИЗВ((A2=$B$2:$B$17)+0), которая рассчитывается для каждого элемента первого списка.

Эту же формулу можно использовать и в Условном форматировании.

СОВЕТ:
Более подробное сравнение 2-х списков описано в статье Сравнение 2-х списков.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 4.5 (2 оценок)

Комментарии

Олег

Поясните, пожалуйста, зачем в конце формулы добавлено "...+0"?

Creator

Дело в том, что выражение A2=$B$2:$B$17 возвращает массив логических значений типа ИСТИНА;ЛОЖЬ;ЛОЖЬ;... значение ИСТИНА эквивалентно 1, а ЛОЖЬ - 0. Эквивалентно, но не равно, т.к. это разный тип значений. Функция СУММПРОИЗВ() складывает только числа, поэтому нужно предварительно превратить массив ИСТИНА;ЛОЖЬ;ЛОЖЬ;... в 1; 0; 0;... Это можно сделать с помощью любой математической операции, которая не изменяет само значение, но изменяет его тип. Например, +0, -0, *1, /1, ^1

Олег

Как сделать так, чтобы в файле примера в столбце D появлялось значение столбца А, отсутствующее в столбце В? Например, "Текст 3", "Текст 5" и т.д.

Creator