Изменяем в MS EXCEL денежный формат с российского на американский

В России принято записывать денежный формат в виде 123 456 789,00р. В США десятичная часть отделяется от целой не запятой, точкой, а разряды не пробелом, а запятой. Если требуется отобразить денежные суммы в американском формате $123,456,789.00, то можно использовать пользовательский формат.

Попробуем отобразить число 11234,33 в американском денежном формате $11,234.33 (см. файл примера).

Использование формулы

Неочевидным подходом для получения желаемого результата является использование формулы и, соответственно, дополнительной ячейки, куда эта формула вводится:
="$"&ПОДСТАВИТЬ(ПОДСТАВИТЬ(ТЕКСТ(B1;"# ##0,00");",";".");" ";",")

Сначала с помощью функции ТЕКСТ() переводим, содержащееся в ячейке B1 число в текст, с использованием формата "# ##0,00". Затем, функцией ПОДСТАВИТЬ() заменяем запятую, отделяющую десятичную часть, на точку. Вторая функция ПОДСТАВИТЬ() заменяет пробелы, разделяющие разряды, запятой.
Недостаток формулы состоит в том, что получаемое значение – текст, а не число.

Пользовательский формат через формат ячеек

Если нет желания переводить число в текст, то с помощью пользовательского формата можно изменить, лишь отображение значения в ячейке, а не само значение. Но без использования дополнительной ячейки все же обойтись не удастся. В ячейку B3 введите =A1*100, чтобы убрать дробную часть.

Пользовательский формат ячейки B3 введем через диалоговое окно Формат ячеек. Для вызова окна нажмите CTRL+1. Выберите (все форматы), удалите все из поля Тип и введите в него формат [>100000000]"$"#","###","###"."##;[>100000]"$"###","###"."##;"$"0"."##

Пользовательский формат и функция ТЕКСТ()

Другим способом отразить денежный формат в американском стиле является использование функции ТЕКСТ():
=ТЕКСТ(B1*100;"[>100000000]$#\,###\,###\.##;[>100000]$###\,###\.##;$0\.##")

Формат в функции ТЕКСТ() отличается, от того который мы использовали в предыдущем случае, тем, что специальные символы . (точка) и , (запятая) закомментированы обратным слешем (\).

Изменение настроек EXCEL

Формат разделения разрядов и целой и дробной части можно изменить в самом EXCEL.

  • войдите в параметры EXCEL (Кнопка офис/Параметры Excel/Дополнительно);
  • в разделе Параметры правки снимите галочку Использовать системные разделители;
  • введите для разделения целой и дробной части точку (.), для разделения разрядов запятую (,).

Естественно, это не выход, т.к. эти настройки повлияют на все книги EXCEL.

Еще более радикальный вариант – поменять Региональные параметры в Windows (кнопка Пуск/Панель управления/Язык и региональные стандарты). На вкладке Региональные параметры поменяйте Язык на Английский (США).

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 3.7 (3 оценок)