Функция СУММ() и операция сложения (+) в MS EXCEL

Есть ли разница между сложением значений с помощью функции СУММ(), английская версия SUM(), и операцией сложения (+)? Оказывается разница есть.

Не смотря на неудобство применения операции сложения для диапазонов (приходится вручную вводить много слагаемых, например =А1+А2+А3+…+А10), у нее есть одно существенное преимущество перед функцией СУММ() – перед сложением эта операция пытается преобразовать слагаемое в число. А функция СУММ() просто проигнорирует нечисловые значения, но что еще хуже - проигнорирует числовые значения в текстовом формате.

Проведем эксперимент. В ячейку А1 введем число 10, а в А2 введем значение ’20 (перед значением введем апостроф, который говорит EXCEL, что введено текстовое значение, подробнее в статье Автоматическое преобразование формата ячейки при вводе текстовых данных (часть 1).

Формула =СУММ(A1:A2) вернет результат 10, а =A1+A2 вернет 30!

Другой вариант сложения - замечательная функция СУММПРОИЗВ(). Эта функция сочетает преимущества обеих формул: удобство и подсчет чисел в текстовой формате. Записав формулу =СУММПРОИЗВ(1*A1:A2), получим результат 30, т.к. из-за операции умножения на 1, EXCEL преобразует (там где это возможно) все текстовые значения в числа (с функцией СУММ() в прямую такой фокус не пройдет - ее нужно будет вводить как формулу массива).

Если преобразование в число невозможно (например, если вместо ’20 введено слово Яблоки), то формулы =СУММПРОИЗВ(1*A1:A2) и =А1+А2 вернут ошибку #ЗНАЧ!, а СУММ() – правильное в данном случае значение 10.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 4.1 (7 оценок)

Комментарии

Алишер (не проверено)

+ лаконичность и по сути (нашел поисковое)

Яндекс.Метрика