Функция ЕПУСТО() в MS EXCEL

Задача функции ЕПУСТО(), английский вариант ISBLANK(), - проверять есть ли в ячейке число, текстовое значение, формула или нет. Если в ячейке А1 имеется значение 555, то формула =ЕПУСТО(А1) вернет ЛОЖЬ, а если ячейка А1 пуста, то ИСТИНА.

Синтаксис функции ЕПУСТО()

ЕПУСТО(значение)

Значение - значением может быть все что угодно: текст, число, ссылка, имя, пустая ячейка, значение ошибки, логическое выражение.

Использование функции

В файле примера приведены несколько вариантов проверок:

1. Если в проверяемой ячейке содержится число, текстовое значение, формула, то функция вернет логическое значение ИСТИНА.

2. Если проверяемая ячейка пуста, то функция также вернет логическое значение ЛОЖЬ.

Проверка диапазона ячеек

Функция ЕПУСТО() проверяет содержимое только одной ячейки. Чтобы подсчитать количество пустых ячеек в диапазоне, то используйте функцию СЧИТАТЬПУСТОТЫ(), но если ячейки содержат значение Пустой текст (""), то функция СЧИТАТЬПУСТОТЫ() будет подсчитывать также и эти ячейки наряду с действительно пустыми. Об этом читайте в статье Подсчет пустых ячеек.

Чтобы ответить на вопрос "Есть ли хотя бы 1 пустая ячейка в B6:B11?" используйте формулу массива

=ЕСЛИ(СУММ(--ЕПУСТО(B6:B11));ИСТИНА)

Чтобы ответить на вопрос "Есть ли хотя бы 1 заполненная ячейка в B6:B11?" используйте формулу массива

=НЕ(ЕПУСТО(B6:B11))

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 3.7 (6 оценок)