Диапазон дат в одной ячейке (в текстовом формате) в MS EXCEL

Выведем диапазон дат (начальная - конечная дата) в одной ячейке в формате 21-25.10.2012.

Пусть задана начальная дата (ячейка B7) и длительность периода (ячейка B8), выведем диапазон дат в одной ячейке в формате 21-25.10.2012 (см. файл примера).

Это можно сделать с помощью формулы =ТЕКСТ(B7;"дд")&"-"&ТЕКСТ(B7+B8;"дд.ММ.гггг")

Совет: О пользовательском формате дат можно прочитать в статье Пользовательский формат ДАТЫ и ВРЕМЕНИ в MS EXCEL

Это решение, однако, не учитывает, что начальная и конечная дата могут принадлежать разным месяцам. В этом случае формула может вернуть, например 21-05.10.2012, что довольно сложно для понимания. Поэтому, изменим формулу: =ТЕКСТ(B7;ЕСЛИ(МЕСЯЦ(B7)-МЕСЯЦ(B7+B8);"дд.ММ";"дд"))&"-"&ТЕКСТ(B7+B8;"дд.ММ.гггг")

Теперь. если начальная и конечная даты принадлежат разным месяцам, то у начальной даты будет дополнительно выводиться месяц.

Диапазон с указанием месяца и года

Более простым случаем является вывод начальной даты с указанием месяца и года (что позволяет корректно учесть случай, когда даты принадлежат разным годам). В этом случае нужно использовать формулу =ТЕКСТ(B13;"дд.ММ.гггг")&"-"&ТЕКСТ(B13+B14;"дд.ММ.гггг")

В формуле предполагается, что начальная дата введена в ячейку B13, а длительность периода введена в ячейку B14.

Диапазон в пределах 1 месяца

Иногда требуется, чтобы начальная и конечная даты принадлежали одному месяцу. В этом случае в формуле необходимо провести проверку: не выходит ли конечная дата за границы месяца. Если конечная дата выходит за границы месяца, то она заменяется последней датой месяца.

=ЕСЛИ(B19=КОНМЕСЯЦА(B19;0);"Последний день месяца";ТЕКСТ(B19;"дд")&"-"&ТЕКСТ(B19+МИН(B20;КОНМЕСЯЦА(B19;0)-B19);"дд.ММ.гггг"))

В формуле предполагается, что начальная дата введена в ячейку B19, а длительность периода введена в ячейку B20.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 4.7 (3 оценок)