День недели в MS EXCEL

Определим день недели для заданной даты в ячейке. Существует несколько решений в зависимости от того результата, который мы хотим получить: номер дня недели (1 - Пн, 2- Вт, ...), текстовую форму (Понедельник, Вторник, ...) или просто можно изменить формат ячейки.

День недели можно быстро отобразить с помощью Пользовательского формата. Пользовательский формат можно ввести через диалоговое окно Формат ячеек, вкладка Число, (все форматы), нажав CTRL+1. Для отображения вместо даты дня недели, на который она приходится, в поле Тип, предварительно все из него удалив, нужно ввести ДДД (краткий формат дня недели, например, Сб) или ДДДД (будет отражено Суббота).

Другим способом, определения дня недели является преобразование даты в текстовую форму с определенным форматом (см. файл примера):
=ТЕКСТ(01/01/10;"дддд")

Формула вернет текстовое значение "суббота".

Для определения дня недели через числовую форму (понедельник=1; вторник=2, …) существует функция ДЕНЬНЕД(), английская версия WEEKDAY().

Если дата находится в ячейке А1, то формула =ДЕНЬНЕД(A1;2) вернет день недели. Номер 1 соответствует понедельнику.

Для того, чтобы вывести день недели на английском языке используйте формулу =ТЕКСТ(A6;"[$-809]ДДД")

Другие статьи на эту тему можно найти в разделе Неделя, День недели.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 3.8 (5 оценок)

Комментарии

MCH

Функцию =ДЕНЬНЕД(A1;2) можно заменить на =ОСТАТ(A1-2;7)+1, иногда это удобнее

Виктор (не проверено)

Добрый день. Работаю сейчас над понедельным отчётом о работе отдела. Надо привязываться к дню недели, а это каждый раз разная дата месяца. Надо брать данные с соответствующего дате листа в этой же книге. Возникает вопрос: А есть ли вариант подставить в формулу в качестве ссылки на лист значение другой ячейки? Например, формула в ячейке D7 сейчас ='2'!$P6 (берём значение зафиксированной ячейки с листа 2), но так как будет меняться из месяца в месяц, а формул - тьма, то способом снизить вероятность ошибок было бы задавать в определённой ячейке дату. Например ='D2'!$P6, но такая формула выдаёт ошибку.

Creator

Попробуйте использовать функцию ДВССЫЛ() Функция ДВССЫЛ() Эта функция позволяет сформировать ссылку на лист в текстовой строке. Если не получится пишите на  creator@excel2.ru

Яндекс.Метрика